Upgrade Architecture on IPFire Duo Box

I purchased an IPFire Duo box in 2016 that has been running great. Recently when I tried to upgrade I received the “Almost out of space on /dev/sda3” message and also an indication that I am running an outdated architecture (the i_586). Since the latest two updates failed due to the space issue, I am currently running core 158.

I am happy to upgrade the system to the 64-bit version, but I need to reinstall the full version and then apply the backed up settings. This is proving more challenging than anticipated.

The main challenge is getting the system to boot the iso from the USB drive. The Duo has two HDMI ports, but neither of them appear to be active as plugging in both a monitor and usb keyboard provides no output. There is a serial port on the front of the Duo, but it does not appear to be enabled as a serial terminal as I am unable to connect using this port.

I have both ssh and web access to the unit, but can find no option to set the bios to boot from the usb, or to run the image on the usb.

The device originally came with ipfire installed and I was able to do the configuration from the web interface, so short of disassembling the unit and writing the image directly to the hard drive, I am not sure how to load either a new image or to restore a backup image from an ISO.

I would appreciate any suggestions and/or information about the Duo hardware that will allow me to move forward.


This probably won’t help you, but I have a Duo Box from 2017 and had no problem booting from USB just yesterday. There was nothing for me to do, just connect HDMI to a monitor and plugin the USB stick. I used the front port for that.

One problem though: When I had my external USB hard drive connected (rear port) to create an image with Clonezilla, I only got a blinking cursor on the screen. Hat to disconnect the drive to be able to boot.

1 Like

I have two of them. The second one in case of desaster means, the first one failed. I already tried my desaster recovery process to check if it works. So I made a clean install of base system from a bootable usb stick and wrote back my image from the first one. Because of different nics (mac-addresses) the mapping of red, green etc interface is lost. So I have to connect a Monitor via HDMI to setup the nic/network-config from console.
Long story short, both, connecting a monitor via hdmi and booting a usb stick works fine.

1 Like

Which HDMI port are you using as I seem to get no display from either monitor port.

The upper one (when the box is oriented in a way that the LEDs from the LAN ports are at the bottom).

For reference

Thanks to all. It is now working properly. It would appear that “rebooting” ipfire is not the same as a cold boot in that the system appears not to rescan the attached devices. After connecting the monitor and keyboard, shutting down the power, and then doing a cold boot the system recognized that a monitor was attached and loaded the display drivers (apparently not loaded or enabled if a monitor is not attached). At this point everything is working as it should.