Unforeseen Error took place in /ect/rc.d/rc3.d/S65mpd

I have been getting this after the last updates.

"You Should not be reading this error message
It means that an unforeseen error took place in /ect/rc.d/rc3.d/S65mpd, which excited with a return vaule of 127."

I have looked at the logs that I can’t find and it is showing nothing. Anyone know how to resolve this issue?

Try to start mpd on commandline to see the reason of this error. In most cases it is a not installed lib like libffmpeg or a missing directory.

Thank you for the reply I am new at IPFire command what is the command to start the mpd? Also I look at the file and it is blank as well.

Normal /etc/rc.d/rc3.d/S65mpd is not a file. It is a symlink that points to /etc/rc.d/init.d/mpd
If this not exist mpd is not correct installed. Run
pakfire remove mpd
and delete the symlink.

After this you can reinstall it if you want use the music player daemon.

Sorry it took so long to reply and thank you for your help.
I ran the “pakfire remove mpd” and got

PAKFIRE WARN: mpd is not installed
PAKFIRE ERROR: No packages to remove. Exiting…

I tried thius as well…

pakfire remove S65mpd

PAKFIRE WARN: S65mpd is not installed
PAKFIRE ERROR: No packages to remove. Exiting…

I also CD in to the Dir

[root@XXXXXXXXX ~]# cd /etc/rc.d/rc3.d/
[root@XXXXXXXXX rc3.d]# dir
S01vnstat S15messagebus S24cyrus-sasl S30sshd S50bird
S10sysklogd S19smartenabler S25cups S32apache S60monit
S10watchdog S19wlanclient S26ntpd S33clamav S65alsa
S11unbound S20network S29collectd S40fcron S65avahi
S12acpid S21leds S30asterisk S45guardian S65mpd
S15fireinfo S22conntrackd S30dhcp S45samba S98rc.local

Just to let you know I am kind of new to IPFire but long time Linux user.

remove the link:
rm /etc/rc.d/rc3.d/S65mpd

1 Like

That was the ticket thank you very much.

1 Like