Trouble with Installing IPFire onto raspberry Pi 3


I am trying to install IPFire for the first time on a Raspberry Pi 3. The installation process seems pretty straight forward, but I am unable to get the raspberry pi 3 to boot past the rainbow splash screen. I have had a bit of a google and tried a number of things to get IPFire to start up.

I have followed the guide on the IPFire wiki. Including changing the on the SERIAL-CONSOLE=ON to OFF

and the raspberry pi I am using is a “Raspberry Pi 3 Model 3 V1.2”

So far I have tried:

Downloading the image file from the official site ( - IPFire 2.25 - Core Update 156 ) - Both the direct link and the torrent.

Flashed the image using Etcher and Rufus - Both ways hang on the rainbow screen.

Changing the power supply - Still hangs on the rainbow screen, will boot fine in to LibreELEC and Raspbarian.

I have tried to replace the kernel file with a working filek off the LibreELEC SD card - Same result, hanging on the Rainbow screen.

Using a different Raspberry pi 3 - Both raspberry pi’s hang on the rainbow screen, and will load LibreELEC.

Installed Raspbarian on to the SD card ( ) - Boots straight into the installation process.

I have had the idea that the SD card is corrupted suggested to me, however I am doubtful of this as it is a new SD card with very minimal use, and the fact that Raspbrian has been successfully booted from it.

I am open to any suggestions at this point.

Also has anyone successfully downloaded the image file and installed IPFire in the last couple of days? Is there a any chance the current image file is corrupt?

Thanks for sticking through the wall of text, looking forward to any suggestions.

Did you check the sha256 sum of the file you downloaded against the sha256 value on the download site.
If they match then the image on the website is inlikelyvto be corrupted.

Thanks for the reply, this is my first time using Sha256sum. It looks to me as the file hasn’t corrupted during the download process.

I thought it may be that I have been impatient with the splash screen, but since my original post I have flashed IPFire back on to the SD card and left it on the rainbow splash screen for approximately 45 minutes.

(as a new user it would only let me upload one image)

I would doubt that the file on the IPFire download site is corrupted but you could download the previous Core Update 155 image and see if that works for you.

If that also has the same problem then I would believe that the issue is not with the IPFire images, although I can’t help you with what the problem might be.
If Core Update 155 image works for you then there might be a problem with the 156 arm image.

I only use RaspberryPi as a small dhcp server on my Orange DMZ network and I am running it with Arch Linux. I have no experience of installing IPFire on a RPi

Thanks for the link, I wasn’t able to find previous versions myself to test.

I highly doubt it too, but I have absolutely no idea what it could be. I am currently running a Bad blocks test with Rufus to be 100% sure it isnt the card. After that has run and flashed 1.56 onto the card again I will test it and if that fails to work I’ll try the 1.55.

Thanks very much for your time.

I was able to complete the bad block check successfully with no errors reported on the SD card.

Unfortunately the 1.56 release failed to get past the rainbow splash screen and the 1.55 also failed to get past the rainbow splash screen.

Also tested with a boot delay with, no luck.

I think for now I have to accept defeat.

If anyone has any new suggestions I am still keen to try them.

FYI - another thread about issues with Raspberry Pi 3B. (haven’t found a solution yet)

If you plug the SD Card into another computer, do you see files?

EDIT: I just saw you were a part of that thread also!

Hi Tyson,

I wouldn’t expect the image for the Raspberry Pi to be problematic:

That’s been my gateway/firewall running on a Raspberry Pi 3B for the last 3 weeks. I followed the instructions here and don’t have boot issues.

When you write “rainbow screen”, do you mean the screen with four (colorful) burning penguins at the top? Is there any text that might indicate what the problem could be?