There are no unassigned interfaces on your system

Hi everyone.
Did you know how solve this problem… I’m install ipfire in Virtual Box but when require me the interface GREEN and RED only have one pc1 for the GREEN.

Someone know how solve this problem. I’m new in this :frowning:

Create two interfaces in VB – one is bridged and that will be red0 (DHCP) from your host network. Create one more interface, Host only adapter, that will be green0, static, your network. Make note of the mac addresses so you know which one to assign to red, green.

image

See wiki.ipfire.org - Oracle Virtual Box

3 Likes

Thank you! I solved that

One more thing :slight_smile:
What ip address is recommended to use. In internet the people use different ips but i don’t understand why

You could use any ip you like (see Private network - Wikipedia) but … VB has its own DHCP server so if you configure your green as 192.168.56.10 then you can access the WUI https://192.168.56.10:444/ from your host pc (the one where VB is running).

But if you want to use 192.168.0.1 then you need to start another VM with one adapter, Host-Only and from that VM you can access the WUI as https://192.168.0.1:444/ That VM should get an ip in the 192.168.0.something assuming you configured green to provide dhcp range, eg. 192.168.0.100-200

I was waiting for your reply XD I will use the first ip (192.168.56.10)
Thank you very much

Alice

In VB, File > Host Network Manager you will see the DHCP info.

tab adapter screen
image

tab DHCP server screen
image

You have to click enable so that VB starts its server.

Yes i checked that.
And now I get this

Can you access the WUI via https://192.168.56.10:444/
If so, look at Network > DHCP server if it is active.
In my example I used VB’s DHCP server, not ipfire’s DHCP server.

Well. I disabled DHCP.

I have this…

Did you forget the s in https://192.168.56.10:444/ the browser should ask you should I trust this ip, you say yes and then it will ask for credentials, admin and your pw (not the root pw)

In the browser it didn’t show but the https is hidden.

The problem continue. I think is for the DHCP

Do not check the VB DHCP server in Host Network Manager, let ipfire handle DHCP requests.

You can check in ipfire console if httpd is running … if not, some configuration is wrong.