SafeSearch not working with Apple Devices

I have a strange behaviour when activating SafeSearch: it is working correctly with Windows PC (tested with 3 different PC), but it doesn’t work with Apple devices (1 Mac and 2 iPhones).
Has anybody the same problem?

No, this has been confirmed to work with all devices.

It takes some time for changes to become active after you have enabled Safe Search.

Good night Michael.

Sorry for not understanding how “Safe Seach” works.

From what I understand, by activating this check, if you search on Google, for example, “porn”, all explicit content should be filtered. It’s not like that?.

I have it set up like this:

And I can assure you that if I put “porn” on google, everything appears to me.

This check has been active for several days.

Thanks for the clarification.


1 Like

I configured exactly like you did, and it works for Windows but not for Apple devices.

Before Core 141, I created the file /etc/unbound/local.d/blocklist.conf with the list of all google url pointing to GoogleSafeSearch IP ( and it worked for all devices.

I will make more tests tonight.

I’m in the same situation of Roberto Peña.

Safe search is not working or i do not understand how it works
or what to do to make it work.



Yes, same problem here.

There is a file in the /etc/unbound directory called safe-search.conf.

There is no entry in this file, it is empty …

In the file unbound.conf, the file safe-search.conf is not called up for me and is loaded when unbound starts?



There are two bugs in the unbound initskript.
google is not working because there is a wrong “:” after local-data
and the reload function build the localdata and throw it away.

I have fixed this and changed the order of the time-fix which also
should run before generating the localdata;a=commit;h=770a1507dd750fe98f327919c9da576d6b996469

@arne_f, can we have these fixes in Core Update 142?

1 Like

There is still a bug in this script. I have not erased some lines at tranfer to the git.
I will remove the uneeded remove-forwarders parameter and then rebuilt core142

I tried the file from git (after removing lines 620-622) and Google SafeSearch is working correctly.

Yes, how works ok.