Roku Streaming Apps

Anyone is running a Roku streaming device or Smart TV behind IPFire?

I am having issues with most of the Apps not streaming videos. Apps will load and let you browse but when you click play it will just give me an error. Youtube app will just keep loading or black out.

Apps that are not working: Youtube, Amazon VIdeo, Hulu,
Apps that working: Neftlix, Fox, are working fine.

Streaming videos works fine using a browser o a PC but not using an App on Roku.

Location block (GeoIP) is ON.
Proxy is OFF
URLblock is OFF
I don’t see anything blocked on a blocklist,

The only thing I see in Firewall Log is:

OUTGOING on Green0 From RokuIP


The destination IP’s seem to be for AWS, and DigitalOcean
but not even sure if this is related to streaming

I can’t pinpoint anything else even in the IPS log.

Perhaps this will help.

1 Like

Hi Trish - I don’t use a Smart TV but I do have Apple TV (and many Apps) and that works very well.

Try turning off Location block / GeoIP temporarily (until this is fixed).

Curious what is the setting for Default firewall behaviour (menu Firewall > Firewall Options)??

I’ll dig up my old Roku device and plug it in later this week. Too many other items on the to-do list today and tomorrow!

1 Like

Plugged in and set-up the Roku. All works A-OK with the apps: Netflix, Fubo & Apple TV. I did not add any firewall rules for the Roko.

1 Like

Thank you for all the replys/

Netflix is the only app that works without issues.
Amazon, and Youtube kind of started to work around 1:30 AM, weird maybe there is a bandwith issue because they both don’t work during normal hours.

I will try to turn off Location block, although it only blocks incoming connections right?

The ports for Hulu are outdated, not working.

Here are my firewall options, I think it is basically default whatever shipped with IPfire

I can try Amazon and Hulu tomorrow.

Can you send the error you see? Maybe a picture or the error?

Thank you Jon,

I see my QoS is NOT RUNNING.

Here is the Hulu Error

Hulu works A-OK for me. No errors.

Try turning off Intrusion Prevention System / IPS temporarily (until this is fixed).

It probably is a bandwidth issue more than an IPFire issue.

What are the Internet Service Provider (ISP) provisioned upload and download speeds? (i.e., what speeds do you pay for?)

You are right, it could be bandwith. The speed is 70/7 . But it could be that the whole neighborhood is watching Hulu at the same time.

have three roku’s, 70mbup, 5mb down, all three playing find on all those channels no problem IPS and GEO block enabled. Also bandwidth not big issue as do roku (netflix), VPN, VDI sessions from my moms house on a 10mb DSL up 1MB down.
May be way GEO block and/or IPS is setup maybe ?
what looks like in that log
DROP_NEWNOTSYN means received a packet that was not the start of the required 3 way handshake for the TCP connection, first packet not the SYN packet ?

I am running 3 Rokus, 2 Roku TVs, 1 Vizio smart TV and several computing devices accessing Netflix, Hulu, Youtube TV, Philo, Vudu and many other streaming services with no issue.

What Roku devices are you using? I had a Vizio smart TV where Hulu stopped working earlier this year, but I found that was because the app wasn’t updated for 3 years, and Vizio never released an updated version. I ended up getting a Roku Premier for the TV, which resolved that (and a couple of other) streaming issues I was having. I have a couple of older Roku 2s that I stopped using because they couldn’t adapt to the newer capabilities of some of the streaming services I was using as well.

Was burnt by this too.
You should read some of the horror stories about Samsung smart TV,s.
I would recommend a dedicated device.
Like Roku.etc.When it becomes outdated cheaper to replace than whole TV.

1 Like

Hi, Trish. Did you get this worked out? I’m running a variety of Media streaming devices (including 3 Rokus) on my network behind IPFire.

If you haven’t figured out the issue, can I suggest checking whether or not you can stream Hulu, Amazon, and YouTube from a computer on your local network? That will allow us to identify whether it’s a network-wide issue, or simply an issue with the configuration of the way your Roku is handled.

1 Like

I have a smart TV, with that has some proprietary apps.
The roku I am having trouble with is a Roku Streaming.
Version 9.4

This could explain why Youtube didn’t work:, some people blamed Roku, some people blamed Youtube:
[](https://Roku update Breaks YouTubeTV)

@Jon @mwclarke13
IPS is not the culprit:

  1. I used to have Roku on the Whitelist
  2. I turned IPS OFF and it made no difference, same error

“We are having trouble plating this”
sounds like it can’t connect to the streaming server??

Streaming videos works fine using a browser on a PC but not using an App on Roku.

@trish I’m, admittedly, an IPFire newb, so I’m just trying to help identify what could be the issue.

Are your PCs on the same subnet as the Roku?

The PC(s) that you’re using to test, are they wired or wireless? Is the Roku wired or wireless?

Do you have any other streaming devices on your network (Chromecasts, Firesticks, etc.)?

Could there be an IP conflict with another device on the network? It may be helpful to install the WIO (Who Is Online) add on to identify this.

Are you on the latest firmware on Roku?

Thanks for trying to help. Everything is on the same subnet and wireless,

Roku is wireless, PC’s wireless.
Other streaming devices: I have a smart TV
I don’t think there is an IP conflict, but I will checkout the WIO addon.
Yes I have the latest Firmware, I wonder if that;s the culprit, because meanwhile many people on that new firmware started to experience the same issues.

I guess it is just a freaky coincidence that when I started to use IPfire for Roku, a bunch of apps stopped streaming while others where working fine. Later people started reporting massive Youtube outages, and lately I discovered that the error I get from Hulu is just a generic error that tons and tons of people are getting.

The fact that there is nothing much in the logs was the confusing part.