Reinstallation of ipfire with restore of Backup does Not work

I have installed a new System with the actual Image and restore the Backup of the old System.
After restart the System is not working as expected.
Root console works fine.
Do i have to do any additional configuration?
Best regards

It is impossible to tell what went wrong based on your post. Please be more specific.

1 Like

I check the system and get access to the web page.

DHCP service is not running!

I installed the actual " IPFire 2.25 (x86_64) - Core Update 146" and the
backup was from a 32 bit machine (core 145).

DHCP Logs did not show any entry in the admin web page.

After I entered
/etc/init.d/dhcp start
the service started and was shown green in the status line.
After the next reboot of the system, the service is not starting again.

I run the command from
to get the graphs correct.
I will continue tomorrow with testing

Best regards

Have you checked that GREEN is set to DHCP ? This setting is in both GUI and /var/ipfire/dhcp. The latter should contain an empty file “enable_green”, plus the parameters in file “settings” need to be compatible with those in GUI.

If that does not correct the problem you might do better to:

  • get core 145 x86_64 from archives and install
  • restore backup from core 145 i586
  • run arch-change commands
  • then upgrade to core 146
1 Like

the complete installation (includes fhem) is now finished and my system is running now with the latest version on 64 bit.
The Problem with the not running DHCP service was easy to solve, if you know what to do.
Just deactivate the DHCP for all network card and activate the DHCP again.
After this, the service was running well after reboot.

Best regards

All right, marking this as “solved” then…

This issue has been written up many times in the community, and what most folks who are panicking don’t take the time to check, is a search for failed restores. Since this seems to happen more often when the user’s 32-bit installation root folder has run out of space, it’s usually performed on a new pc, or second pc, while the first one is still running. Either way, the process is error-prone and if I were to ask Peter for an enhancement, it would either be to add some logic to the 64 restore to check if the backup was coming from 32-bit and then apply some “clean-up”, or to flag the user with a URL that documents some follow-up steps that are needed.

In addition to your DHCP service not running, you’ll also find that your performance graphs will be broken as well. Yep, this is also been discussed in the blogs, so a search will help you out there without the need for a new thread.

From my perspective (as you might guess that I’ve been through this) the backup contains a bit more than is really needed. It’s like it had great intentions to be almost “clone-like” for a failed system, but over time, some of the items just don’t seem to make sense to backup. I think if the critical items that no one wants to re-enter are saved, with everything that’s needed to make a replacement completely functional again (yes, even with different NICs - and some detection when there are difference NICs to prompt the user for which to use red/green/etc. ) it would prevent such issues as this.

As for going from 32-bit to 64-bit, I can’t voice any opionion there. Frankly I was AMAZED that it mostly worked! So cudos to the devs who were part of that, and thanks to the community for providing notes on how to get that last 10% working when you do need such a restore.


1 Like

one trap I was falling into, was the restore of the addon.
I thought, that when I restore the add ons, it will also install the add on .

But you have to install the add on first and restore then the setting.

Best regards