RED no longer connects

Recently my APU2D4 router running IPFire 2.25 (x86_64) - Core Update 142 stopped connecting to RED. Going into setup showed the network settings as it should be, so I assumed something got corrupted. I’ve re-installed IPFire and RED connects and everything seems to work correctly.

That being said, I do not shutdown the router properly from the web admin page as it takes way longer than it really should. I just power off the router quick and easy. My assumption is that powering it off this way gives it the possibility to get corrupted.

If this happens again, is there some error message or logs that the developers would want to see? If so, what would that be?

I found a user with a similar problem:

1 Like

it is recommended you turn off your firewall from the menu instead of pulling-the-plug or you may get a corrupt filesystem which you may/not recover from. Can’t you leave the firewall on 24/7 ?

I use the router in my single person household and wish to keep my electricity bill as low as possible, so the router gets powered off when I’m done accessing the internet. So no, I don’t wish to leave my router on 24/7. That being said, it’s gone roughly four months of being powered off repeatedly on a daily basis before this happened.

Would using a different file system at install time of IPFire change the susceptibility to this problem? Or perhaps a text file setting change?

If this corruption happens often enough, I may have to get into the habit of shutting it down correctly. But I won’t like it. LOL

With your scenario I would do the official shutdown process. Thus all running processes and disk activities are stopped in a controlled way.
You never know exactly when there is no disk access. You could examine this, but why. The shutdown time is shorter than your examination.

Why does shutdown time matter ? This is a low wattage router and repeated power cycling might hasten its demise.

If you run fsck.vfat /dev/sda1 then it will probably report that the filesystem was not shutdown properly. fsck does not fix anything on vfat - simply deletes orphan items and that can eventually lead to the system not booting. You don’t have the option to change this filesystem, at installation stage.

On an APU2 sda1 should be ext4 but depending on the installation (iso or flashimage) it has enabled or disabled journal. Enabled journal is not good for cheap flash disks like sdcards but a bit more reliable on unclean mounts. But anyway linux doesn’t like unclean shutdowns.

On the board the APU2 should have a button or pinheader for clean shutdown.

Because I have other things to do than wait around for computers. My desktop Linux distributions Linuxmint and Manjaro shutdown in a matter of seconds. Why can’t IPFire?

Yes, yes I do.

https://wiki.ipfire.org/installation/step3

Scroll down to “Filesystem Options”.

Arne.F,

I’ve been choosing just the default Ext4 file system. Am I seriously decreasing the life span of what I assume is the SD flash card in it? I honestly can’t remember what the drive in it is and can’t find specifications for it anymore since it is a discontinued model.

While it’s great to know that there is a button on the motherboard to shutdown, the board is fully enclosed in a case with no access to that.

donteatyellowsnow
Linux Mint & Manjaro are probably running in much faster PC, having faster cache, I/O etc and running fewer “mission critical” services, that need careful termination. My openSUSE takes some time to shuddown, because it checks that no running services would be disrupted.

The choice of filesystems at IPFire installation is only for /dev/sda3, which is not where the boot files are and what will cause the boot to fail, if corrupted. As Arne.F has pointed out the filesystem for /boot has limited ability to self-repair