QoS problem after restore on new machine

Hi. I’m hoping someone can help with a slightly weird issue.

Today I upgraded our IPFire to a new machine both on core update 163. The old machine worked fine but was getting old, so this was some preventative maintenance. This was done by getting a single iso from the Backup menu with the latest configuration, burning this to USB and then doing the normal networking setup on the new box. I was pleased to see all the configuration was present and most things worked as before. There were two exceptions. The DHCP service didn’t appear to be running - eventually just pressing ‘Save’ for interface configurations caused that to burst into life.

However the (very simple) QoS is behaving strangely. The graphs show traffic up until I created the configuration backup, but nothing afterwards. I’ve tried stopping, restarting and redoing the simple configuration, but nothing seems to work.

Any help debugging what is going on is much appreciated. Thanks in advance.

likely this is a problem of the graphing system, see this tutorial on how to migrate to new hardware.


Many thanks @cfusco, that’s extremely helpful.

Before I was able to check that method, the graphs started showing information at 1am today. Very strange, but some testing does seem to suggest it is now working properly.

Very odd, but thanks again.