Qemu/libvirt bridge mode on core 159

I selected network bridge under zones in the green. Question what does ‘Native’ mean, here I have set ‘none’. Ipfire restarted afterwards. I noticed that the MAC address of the network cards, in particular the green ones, were swapped, but that was only mentioned in passing, I was able to correct the MAC ‘via’ setup ‘or in the file’ / var / ipfire / ethernet / settings’ again put.

Use virt-manager on the client side via ssh. If I set the network source to bridge in a virtual machine, it doesn’t work and I get the following message: ‘Error starting the domain: Unable to add bridge green0 port vnet0: Operation not supported’. If I set the network source to ‘Macvtap’ instead, I don’t get a message and the virtual machine seems to be running. However, e.g. Nextcloud does not report an internet connection. What am I doing wrong?

This might help.


Thank you very much for the link, but unfortunately I still can’t figure it out. If I should now set a bridge to ‘Native’ or ‘None’ in the green network, I think that the ‘VLAN’ setting remains outside. Does this affect the error described above

before someone answers, just set green to ‘native’ and restarted ipfire.

What can I say it now seems to work, I was able to put it on bridge with virt-manager.

I think my detailed question should have been settled with this. thanks

1 Like