Proxy denies access to own DynDNS from green


I’m running a transparent webproxy as well as a non-transparent on interface green.

When trying to access one of my DynDNS URLs from green, the browser (Firefox) stops this attempt, telling me that the configured proxy does not allow this connection attempt.

The URL is for example
and I’m trying to access one of my internal servers (not in DMZ!) with this URL, btw.

So what’s the deal with this? Any chance to stop the proxy and allow this connection?



could you post a screenshot of your Squid configuration here please?
“Proxy denies access” is unfortunately too generic to give satisfying answers. :slight_smile:

Thanks, and best regards,
Peter Müller


After your request or the configuration, I noticed there is a config setting: allowed SSL Ports that was missing a port, a non-standard port of mine, I was using.

After adding this port and restarting squid, I now can access the URL.

Thanks for reading!

I see, glad things work now. :slight_smile:

iam sorry but i dont see your problem solved. I see only your symptom solved. Let me pls tell my opinion about.

So you try from green with your Firefox to reach your i guess your Syno baikal. Its also in green. You try this with your dyndns. So you have do reach your Syno directly without a proxy connection. Your problem is not your Squid your problem is the missing host entry in IPFire. Sorry if i maybe lead you in a false direction but i think iam right.

Thanks for your reply and yes, you are correct, I would like to reach the Synology NAS in LAN using a DynDNS address. This works for a WebDAV address on the same NAS, but difference is, this WebDAV server uses port 80 which is fine in Squid.

Anyway, I just posted my solution above: I’m using port 55544 to get the correct firewall rule (port forwarding) triggered. This works OK when using the DynDNS from a external client, like a smartphone, but from internal LAN it doesn’t, unless I add this port 55544 to the allowed SSL ports in Squid WebIF.

Reaching the Synology by a DynDNS address is by intention to test, firtst the forwarding rule and second to test if I can reach the NAS with this URL.