NanoPi R1 Stuck on Boot

Hello,
I received my NanoPi R1 as Ipfire have good support for this device.

I flashed the latest image for armv5tel on the sd card and tried to boot from it.

It gets stuck on boot, logs here

I will test in some more ways.

Found out that it have 2 UART so I connected it to the internal one and not I see uboot logs which was missing on the outside UART.

uboot logs here

But it fails to boot completely unless it take some times while I am being impatient.

starting line 196 looks wrong:

mmc0: new DDR MMC card at address 0001
mmcblk0: mmc0:0001 SOD16G 14.6 GiB
mmcblk0boot0: mmc0:0001 SOD16G partition 1 4.00 MiB
mmcblk0boot1: mmc0:0001 SOD16G partition 2 4.00 MiB
mmcblk0: p1 p2 p3

p1 should be 124 MB. Did you zero out the first 8 MB of the uSD card,prior to flashing ?

I’m also a fan of piping xzcat output to dd and setting bs=4M, to reduce wear and speed write.

No I just flashed the image using etcher, is that not supported ?

On your recomendation, I tried extracting the img manually and flashed it using dd and bs=4M
Let’s see if it works.

Update: It is stuck at /etc/mtab
UPDATE2: It was my sd card adaptor as I was testing it with SD card to Emmc adaptor as it is very fast in read write but looks like it was not able to resize it on the first boot, with normal sd card it s booting fine now.

Update3: The image works quite well but due to 100mb card it is a bit slow I will test some more using a 1gb usb to lan adaptor. I tried to test its limit with IDS and as soon as I try to enable it, the device gets overloaded and doesn’t respond to any input, I will try some more stuff like clamav and report back.

Thanks.

Can anyone tell me the limitation of NanoPi R1?

I am just trying to test ipfire on it and once I enable hostap it starts the service and then after few mins I see its stopped.

Same for clamav I enable it and when I go to web proxy it says clamav is not running.

Is it known issue with armv7?

Currently just trying to test this hardware limits and not to put in production, Ive been using opnsense on rk3328 and its working super smooth with 1 vpn but cannot test ids and clamav yet as clamav is not yet compiled for aarch64 yet.

The thing about ipfire is that it have almost every pkg available while it is much snappier than the other one and also the network traffic looks quite smooth too and the graphs are quite helpful for a quick analysis.

Please advice on the above point.

Thanks.

I doubt that it is an ARM7 issue. My cubietruck (Allwinner A20) has be up for almost 10 days and hostapd is “running”. I don’t use Clamav.

I’m one of the 6 reporters of nanopi R1 to fireinfo. IMHO, it’s an unreliable piece of hardware.

  • repeatedly trashes the uboot loader on the emmc
  • reset button does absolutely nothing

If you are seeking a reliable ARM7 board, that is supported by IPFire, then variants of the Bannan Pro are probably still available for purchase. It will be slower than R1 and need a USB-Ethernet dongle

No. This output is correct for the internal 16GB eMMC? This module has two 4MB Bootblocks that are present but unused on NanoPi R1.

Have you boot from uSD or from the eMMC. (from uSD should work with the stock IPFire Image, eMMC need a different uboot that swap the uSD and eMMC module.

https://wiki.ipfire.org/hardware/arm/friendlyelec/nanopi-r1

I have used a R1 around a year as main Firewall. No i have replaced it because it is to weak for my new 100Mbit connection.

1 Like

Yes that was old thing was fixed with using an actual sd card instead of emmc sd card.

Currently testing on sd but will flash it to emmc and swap the uboot, hopefully tomorrow.

Sounds good, can you tell me what all did you use on this?
I am interested im testing clamav, ids, hostap, 1 or 2 client vpn and ad blocker with web proxy. All these for max of 3 -4 users network.

Do you think it can handle all these?

Idk why it is not able to start clamav even though it says starting and then it gets stuck while htop doesn’t really show any peak cpu load but the uart connection gets corrupted until it stablizes the device.
Will try it over emmc tomorrow.

Thanks.

[quote=“arne_f, post:6, topic:3020, full:true”]

A friend is one of the other 6 users, but not very confident with command-line work and has abandoned his R1. If I get mine working reliably then I will try to get his going too. We are both on low-speed 12/2 VDSL links He also has a very low traffic DMZ.

Mine uses about 2% CPU, with base IPFire running. I’ve disabled IPS because it was stopping download of Linux ISO files.

1 Like