Mixed blue wlan-ap + wired lan

Many greetings to all :slight_smile:

I have been using ipfire for many years, before that the ipcop with the add-on wlan-ap.
Everything is perfekt!

I need better coverage for the WiFi and bought a repeater.
Unfortunately, the throughput is poor.
Can I operate the blue network with wifi-ap AND a wired connection to the repeater?
Can I solve this using the zones?
Can I assign more than one assignment (wlan0 + eth0)?

Thank you for your feedback and the effort

IPFire 2.25 (i586) - Core Update 146

I am not sure I understand your question. I think you are looking for a way to create a zone with two interfaces bridged together. In that case, https://wiki.ipfire.org/configuration/network/zoneconf

Hi cfusco,

I’m looking for a way to offer a zone (blue - 192.168.2.0/24) both on the wlan-ap-interface wlan0 and at the same time on an AP that is connected to the interface eth0.

Yes, i think that is a bridge between wlan0 and eth0 for the blue zone .

it is correctly to set the zone blue “native” for wlan0 and eth0 in the zone configuration ?

image

best regards
gerhard

I never did it with the web interface but using scripts. I think what you are proposing, “native” settings for the two interfaces is correct, but for the network “blue” I believe you have to select “bridge”, not “normal”. What I am not sure is if the web interface will make the correct modifications to the networking scripts and create a bridge for you or if you have to do it manually. In case, I can post a script as I did it few years back for a friend.

Edit: I based my scripts on this post of the old forum: https://forum.ipfire.org/viewtopic.php?t=11860

Hi cfusco,

yes I would be grateful if you could provide me with the script

best regards
Gerhard

after trying it out, I found out the following that I would like to share

Zoning saves the script /etc/init.d/bridge …

For the zone assignments BLUE = bridge
wlan0 = native
eth0 = native (although this is actually eth3 = LAN4 -> see ‘ifconfig -a’ -> search according to MAC)

Then before! the reboot
File / var / ipfire / wlanap / settings
File /var/ipfire/wlanap/hostapd.conf
Change interface = from blue0 to wlan0!
otherwise WLAN-AP will not find a WLAN adapter

after the restart wifi works normally and brctl show shows the bridge correctly

brctl show

blue0 8000.02f21aa0ce31 no eth3 + wlan0

for german user:

ich habe nach einigem Probieren folgendes herausgefunden, das ich hiermit teilen möchte.

Die Zonenzuordnung erspart das Script /etc/init.d/bridge…

Bei den Zonenzuordnungen BLUE = Brücke
wlan0 = nativ
eth0 = nativ (obwohl das eigentlich eth3 = LAN4 ist ! -> ‘ifconfig -a’ -> lt. MAC raussuchen)

Dann vor ! dem reboot
Datei /var/ipfire/wlanap/settings
Datei /var/ipfire/wlanap/hostapd.conf
interface= von blue0 auf wlan0 ändern !
sonst findet WLAN-AP keinen WLAN-Adapter

nach dem neustart funktioniert das wlan normal und brctl show zeigt die bridge richtig an

brctl show

blue0 8000.02f21aa0ce31 no eth3 + wlan0

@startrek

Hello,

according to FAQ

Please post in English only.

Thank you.

thank you for your assistance

Hi Community,

i want to realize something similar as gerhard did, but i don’t have a spare nic for the blue zone.

So i tried to set the blue zone to bridge mode and added wlan0 (=blue0) and eth0(=green0) with VLAN 200.

Before the restart i also changed both config-files to wlan0.

After the restart i have the problem that interface blue0 and wlan0 (which just appears when i have the bridge configured) are both down. WlanAP is running, but wireless devices can’t find the SSID.

The AP (OpenWRT) is already configured to VLAN 200 (i hope correctly…) but devices logged in don’t get an IP-Address from the IPFire.

Have i done something wrong. Is this setup even possible?

Except the message “blue0: port 1(wlan0) entered disabled state” i can’t find anything relevant in the logs…

“brctl show” is:
bridge name bridge id STP enabled interfaces
blue0 8000.023593904a24 no wlan0

So eth0 is missing here.

Thank You All very much in advance!

KR,
Max