Major Bug? How to crash the system in 5 Steps EDIT: (Not reproducible by others)

I have encountered a strange problem I could reproduce, but I am not sure if this problem doesn’t affect just my system. So maybe somebody else could try to follow my steps an have a look if he can reproduce that:
(I use the german Translation. Some points may be called in another way. But anybody should understand it)

  1. Go to SSH- Control
  2. Activate “SSH-Control”
  3. Press “Stop SSH-Deamon in 30 Minutes”
  4. On your System, try to connect with “ssh” in the terminal (forget to add -l root! so just use your unix account which doesnt exist on ipfire)
  5. Realize that you forgot to use “-l root” so you press Ctrl + C to abort.

Boom! IPFire crashes. Or at least my System. no SSH, no Webpage, no internet, no networking. The resolution is to reset the System.
Can anybody else reproduce that?


I cannot reproduce this.

I have tried:
aarch64 (rpi3 b) and armv5tel (rpi1)

x86_64 and i586 (both on a lenovo x220 from usb stick)

Also test my home IPFire (core141 armv5tel on NanoPi R1) installation.

I can’t reproduce that either.

Tested with x86_64 core 139, OpenSSH_7.9p1 Debian-10+deb10u2, OpenSSL 1.1.1d

Okay thanks! Thought was was somehow strange. Something like that would already be noticed by somebody.

I mark the tread as solved and try to find out for myself what happens.


ssh produce some heavy cpu load at crypto initialisation and also memory load. Have you tested CPU and RAM.

You mean it could be something with the hardware?
No I didnt. But maybe I should. I will investigate this tomorrow.