IPFIRE on raspberry RPI4 B - mmc1: error -5 whilst initializing SD card error

Hi guys
I need your help.
I just got a new RPI 4B and flashed the aarch64 as described in the wiki.
When I power up the RPI, after 30 sec I see a loop with this info:
mmc1: error -5 whilst initializing SD card

How can i fix this error?


Out of curiosity: I am wondering on how do you want to use the ipfire with the pi? Red on ethernet and green with the wifi?

red and green.

When searching via giggle I see issues related to bad SD cards to bad SD readers (maybe bad pin connections).

So you may want to try a new or different SD card.

The only way I’ve gotten a Pi to work with ethernet & wi-fi is for the red to be wi-fi and green to be ethernet.


Hi Jon

I tested a new ipfire install over a new SD card… it does not work.

I also used another sd , and flashed a normal rasberry OS… and this works!
Then I formatted this sd and flashed the ipfire → no way!

don’t have anything else to try…
any hint?

Which download are you using - the ISO Image or the Flash Image?

Do you use Etcher to burn the image? Or how are you burning the image to the SD card? (please be specific)

I just burned the CU159 aarch64 to an RPi 4B earlier this week and all works A-OK!



  1. I download the .img aarch64 file (flash image)
  2. I format an sd card with “SD Card formatter” software
  3. I flash the .img file via “Win32DiskImager”

do you think that probably i have to use Etcher with the iso image or flash one?

What you are using sounds fine and you shouldn’t have to use etcher. But I’d suggest giving it a try since something isn’t working right.

There is an Etcher for Windows version available. It will format and burn the image to the SD card. Make sure you have the current (CU159 - aarch64) version and the Flash Version.

According to documentation by Armbian project, it is advisable to use Etcher, because it checks the write. This is particularly important for older cards, economy cards or those that have had much use.

SD prep

You should also be able to fsck the partitions on the written card, from an operating Linux


I have the exact same problem.
Just bought a new PI4 3 weeks ago, incl. SD-card “Scandisk 16GB SDHC U10”.
I used etcher to install the flash firmware and upon booting I got the same message in a loop.
Also tried another 16GB D card and even a 4GB SD card, but with the same result.

exact andree, same error like the one I’m facing.
And I gave a try also to etcher and with a different card reader and new SD… no way at all…

Anyhow… as I bought my RPI4 from Amazon warehouse (it is a refurbished article), I suspect that this copy has some issue inside.
Therefore, I will give it back to amazon and reorder a new one.

Just to be sure.

My RPI4 came from raspberrystore.nl and was a new one.
I hope there are more issues so the problem can be fixed.

according to Jon… and to the wiki, aarch64 cu159 works …
which version of RPI4 do you own? mine is RPI4 8GB RAM.
I don’t think that 8GB ram is too much, I guess -:slight_smile:

I have a RPI4 4GB. I tried the aarch64 cu159 flash version.
Also tried it on a RPI3+ which works fine.

Hi all

I got a new RPI 4 from amazon… and still getting the same issue.
I’ve opened bug 12684

let’s see if someone can find a fix…

Let’s hope there will be a solution soon. Thanks for the input Vincenzo!

Tried the version “ipfire-2.27.2gb-ext4.aarch64-full-core160.img.xz” but also the same issue.

A post was split to a new topic: RPi 3B+ with WiFi on Red, green on Ethernet - no success

Same issue found with ipfire-2.27.2gb-ext4.aarch64-full-core162.img and ipfire-2.27.2gb-ext4.aarch64-full-core163.img.

Same problem with



https://mirrors.rit.edu/ipfire/releases/ipfire-2.x/2.27-core166/ipfire-2.27.2gb-ext4.aarch64-full-core166.img.xz .

I flashed the img files using Etcher. I tried with multiple SD card and card readers. No dice. The mmc1 error happens right away.

I have a Pi 4B with 8GB. Is the 8GB version not supported ? I see that the file has “2gb” in the name.