IPFire Office Appliance


Because I’m using ipfire for a while I thought I’d buy one of those for support and usage.

  1. I have a VGA male/male wire + an adapter female VGA/male HDMI to plug into my screen which I know has worked in the past.
    Unfortunately my screens will keep saying ‘no signal’. I tried 2 different screens with no luck.
  2. As soon as I plugin the PSU in, the box starts up, fans start rolling. If I unplug and replug it’s all booting up without touching any button. what’s going on with this device?

Any one has had issues?

I feel like I made a bad buy (I know the product is overpriced - who still use VGA) but I was ready to overlook if I could setup ipfire on it. Now it will probably sit until I can find someone who has an old VGA screen. Am such an idiot, wanna show support and I end up with 1990 hardware.

Even quite recent monitors still have VGA socket. Have you tried using only the VGA cable ?

If your monitor does not have VGA, many TV do and that would be sufficient for configuration of you Office Appliance. Once configured, it is not necessary to have a monitor.

1 Like

Rik, VGA is analog, HDMI is digital. I have adapters to convert HDMI → VGA (for a raspberry pi)

An adapter to convert VGA → HDMI (I assume your monitor accepts only HDMI) .

My suggestion is to look to your friends if one has a VGA monitor to loan you.
After install, you don’t need a monitor, ssh to ipfire will work fine.

1 Like

Now tried on 3 monitors, first is 2 years old, second is 5 years old and third is a tiny hand held monitor to setup servers. They all have HDMI at least. My TV has HDMI but no VGA it’s a 2 year old android based.
As I said I was planning on setting up using a VGA male/male wire + an adapter female VGA/male HDMI which has worked in the past, years ago I admit, but something is wrong somewhere.
I am not going to buy a VGA monitor just for this.
Also I’ve mentioned the device is booting up without pressing the power button and doesnt power off if I press the power button.
I’ve sent an email to ask for a refund and I will send back the product at my expense.
This is not joyful experience, I’m sorry to say. I’ll find other ways to support ipfire, but 1300€ for not being able to use the product is too much.

and I’m obviously aware I don’t need a monitor after install. But if I cannot get to install it defeats the purpose. Also there is an issue somehow with that power button, it’s too many issues at once.

I basically needed an adapter male VGA/female HDMI and had the other way around.
Thanks for your comment, that’s helpful.
ok, I see, so I need to buy another adapter, pff more money to spend again
nonetheless I still have that power button not working, device is booting when I plug in the PSU and wont shutdown if I keep it pressed.
because I’m an idiot, I will buy that adapter and hope to ignore that power button issue.
I’ve been using ipfire for many years as a router for my tiny company so I feel like that was a way to give back but I’m not happy with my purchase, I would have been better off buying hardware from amazon.

if I had to guess - I think you are at the 1st step of the setup routine. Once you have a monitor AND complete the initial setup I am fairly sure the power button will work as expected.

1 Like

just ordered a new adapter, hopefully I should be able to get an hdmi screen working and setup the install is the easy part.
from there, you might be right, the power button might work as expected.
will report in a few days when I received the adapter.


This product isn’t 1990s hardware. It is a modern Intel platform and comes with a very power-efficient Atom CPU.

VGA is standard in the data center because KVM switches that support HDMI are quite rare still. Most customers ask for VGA. However, I understand that finding a screen with VGA is becoming more and more of a problem.

Alternatively you can connect the appliance to the IPMI port and access it that way which is a little bit more complicated, but you would not require a VGA screen for this.

1 Like

I’ve received the adapter (male vga/female hdmi) but I’m still getting the same ‘no signal’ message. I don’t get it.
I’m now trying to connect to the device via https and I see the supermicro page but nowhere did I find the default user/password to connect to.
I also see there is an ssh server but here again, cannot find the default user/password.

This product isn’t 1990s hardware. It is a modern Intel platform and comes with a very power-efficient Atom CPU.

Yes 1990 hardware was a sarcasm, not to be taken literally obviously.
Nonetheless without a VGA screen, it is difficult to get a screen working with this device as I report above and this builds frustration. For IPMI, I cannot find logins default in the doc and nothing in the doc within the package too. I also see there an ssh server running by default on the device but here again, no info on default user/password.

Any idea anyone?

Screenshot 2021-12-22 195019
Screenshot 2021-12-22 195156

IPMI default password is ADMIN / ADMIN (both upper case)

1 Like

Thanks for your reply.

No, it’s not working either.
I found a nutanix post saying that since recently the password is the serial number of the device.
So I’ve looked on the back of the device and noticed in very small PWD something. Tried that and it worked.

basically IPMI creds are:
user: ADMIN
pass: << PWD from back of device>>
Also, this works for the ssh server

This kind of info would be nice to have in the documentation shipped with the device… (or somewhere on the wiki)

Now I’m onto install java for the remote console.

Now I can both run via java or iKVM nice.
I started the install process, setup the keyboard to be-latin1 and next screen I had to type the host and domain which didn’t load be keymap.
So I’ve restarted the process by just rebooting.

Now I cannot input anything, the install process seems stuck on keymap be-latin1, I cannot press enter, I cannot use the Virtual keyboard, this on both screens…
basically I cannot input anything anymore

Still trying to figure why but I’m confused.

ok, seems a reboot is not enough, I have to unplug the PSU completely.
Now I can input, back to install process

ok finally I could reach the end of the rabbit hole.

My experience:

  • expect issues with VGA if you do not have a VGA screen
  • VGA/HDMI adapters are not working whatever direction using an HDMI screen
  • IPMI is the only way for me to install the product (can use java, meh, or iKVM) (IPMI login is ADMIN/ << PWD on the back of the device >>
  • if somehow input is not working anymore, unplug PSU, reboot only won’t do it
  • the rest is as usual for ipfire users.

1300€ is clearly overpriced, support will tell you they will NOT refund you as you are within the 14 legal days limit of sending back your device, this is clearly really not cool, if not illegal.
Anybody, whether an individual or company can get a refund within 14 days of purchase even if they change their mind, this is Europe policy for few years already.
I’ll keep the device as my only way to give back the service ipfire provided me over the years but I will not do it again nor recommend it, amazon has way cheaper and better devices with a legal refund policy.

This is a fine-tuned device which works perfectly with IPFire. It is a great piece of hardware which has a certain price.

Recently, parts have rocketed in price and therefore we had to up our prices as well - just like all other vendors. It is pricy now, but sadly inflation is very high and we have no choice than forwarding this extra cost to our customers, too.

Regarding refunds: We follow the law that applies to us and will of course refund any purchases where this is necessary. However, you cannot confuse consumer rights and those that you enjoy as a business. The rules are different and we have decided to follow them closely. Offering a general extended return policy would just increase the cost of the product which we want to avoid because we want to make our appliances as affordable as possible for everyone.

1 Like