IP Address Assigned by DHCP, Clients won't Adopt

Hello everyone. New to IPFire. Really liking it so far after using a multitude of distros over the years including ClearOS, DD-WRT, OpenWRT, RouterOS, and most recently OPNsense.

The issue I am facing is that the DHCP does not seem to be negotiating correctly with clients. Everything is up and running on the IPFire side, got a good connection to the ISP, can ping out via command line. The interfaces all seem to be in order (RED+GREEN). The DHCP server is running and is assigning IP addresses. However, the clients are not adopting the IP address assigned to them by IPFire. When I plug a client in (win 10 and win 11), Windows assigns an APIPA address rather than the one given to it by IPFire. I unplug the client and windows drops the APIPA address. I plug the client into another router (not the ipfire box) and it gets an IP address just fine. There seems to be something in the DHCP negotiation between IPFire and the clients telling them that a DHCP server is running, but not letting them adopt so they default back to APIPA.

Any ideas as to what could be causing this issue? Anyone seen this before?

I know just enough about Linux and networking to be dangerous. So feel free to break it down Barney-style.

The situation connect a W10 client to IPFire using DHCP is a common use case.
I never heard of your problems yet. Windows going APIPA I am seeing with a not existent ethernet connection only. Windows insists on this state usually :frowning:


tcpdump -i green0 | grep dhcpd 

you can examine the data flow on the IPFire side.
For the Windows side you can examine with Wireshark, for example,

1 Like

I have seen this on occasion and it always comes down to a connectivity issue between client and DHCP server.


I appreciate the help. Here is a photo of the tcpdump showing the connection to the client.

Thanks for the help. I’ve tried different cables and different ports. I even thought it might have been an issue with my win 10 installation so i did a fresh install of win 11. Still no luck but the client works perfectly with the other 2 routers i have in the house. For giggles i ordered a USB internet adapter just to rule out a bad NIC on the client. Should be here tomorrow.

What does your DHCP page look like?

1 Like

Here are some shots of the DHCP page. Had to use elinks since i can’t reach it with a client. Have to post photos for the same reason so i apologize for that.

Second page…

It all looks good. Appears the client is seen but not offered an address. Nothing comes to mind at the moment that would cause this. What happens if you set a client with static IP and connect? Can you access the WUI and internet then?

1 Like

Nope. Unfortunately no luck with that route either. One of the first things I tried was to manually set the client IP to the one that was offered by the DHCP server. Was still not able to connect to either the WUI or Internet.

No connection with static IP means there is a serious routing issue or the NIC used in IPFIRE has some sort of conflict or hardware error. Possible corrupt install as well. I would try a NIC with highly compatible chip and/or try re-install of IPFIRE with check summed ISO


I have little to offer to your problem.
Being the very basic trouble shooter that I am.

1. DNS Domain name system settings.
Is it working?
2. Is the firewall default behavior.
“Forward allow”
3. Are the PC’s using ipv4 or ipv6?
No ipv6 in ipfire.
4. Check hardware connections.
Green to PC one known good cable.
5. Hardware compatability?
6. Hardware install or VM?
Hardware recommended.
7. Corrupt installation.

  1. Reboot IPFire
    Sometimes it really helps.

Thanks for the tips everyone. So I have re-downloaded and re-installed IPFire to no avail. I have also tried different clients. IPFire is running on bare metal. The NICs are listed as supported. This exact setup was running OPNsense just a few weeks ago. I decided to switch from OPNsense for the multi-core support and I was having some issues bridging connections.

So now after trying multiple clients, I am getting the same behavior on all of them. The clients know that they are connected to a router because when I plug in the ethernet cable, the windows client assigns an autoconfiguration IP address in the 169.254.xxx.xxx range. When I unplug the cable from the client it drops the autoconfiguration IP address. It seems the clients are talking with the IPFire box but just not accepting the IP address given to them by the DHCP server.

You need to show us the contents of the dhcp server log when you try and make a connection from a client.

Go to the WUI menu Logs - System Logs and the in the drop down box for Section choose the dhcp server entry and then press the Update button.

Then attempt to make a connection from the windows client and when it has failed then press the Update button again in the dhcp server log and ytou will then see the entries related to that client attempt. That should give some clue as to at which stage the connection is failing.

You should also look at the client dhcp logs on the windows machine to see what sort or messages it is flagging up.


Another tracking of the communication is by
tcpdump -i green0 -v
You should see

  • the request packet from a client
  • ACK for the packet
  • response from DHCP server with IP for client
  • ACK
  • a sequence of DHCPINFORM/DHCPACK packets, all ACKed by the other side.

All packets flow from IPFire to client.
The exact sequence of BOOTP/DHCP… packets I don’t remember at the moment, but this can be looked at the wikipedia article.

If some packets are missing, I assume your ethernet connection is physically/logically defective.
The same packet capture can be done with witeshark on the windows client side.


Thank you for the help everyone, After much trial and error I have conceded that it is a hardware compatibility issue. I am using a dell wyse thin client with a Rosewill brand Realtek NIC (I know, I know, but sometimes you are on a budget). Truth be told I have had issues getting other distros to work on this hardware as well. So for now I’ll have reverted to another distro until I get new hardware. Thanks again for everyone’s support and trouble shooting tips! Definitely added to my understanding of networking.