Installing ACQ107 drivers on IPFire

Stopping/starting the card seems to have no effect No matter what I do the driver does not seem to be able to load.

/var/log/messages keeps recording:
May 5 21:11:34 phoenix kernel: atlantic: probe of 0000:06:00.0 failed with error -12
May 5 21:11:40 phoenix kernel: atlantic 0000:05:00.0: enabling device (0000 -> 0002)
May 5 21:11:40 phoenix kernel: atlantic: probe of 0000:05:00.0 failed with error -12
May 5 21:11:40 phoenix kernel: atlantic: probe of 0000:06:00.0 failed with error -12

Can’t figure out what error -12 means

-Greg

have you tried compiling the source? I found this link which at the very top let’s you d/l the source zip file and then instructions how to compile it. It might be worth a try …

Compiling from the source was the first thing I tried. When I tried loading the compiled module with insmod, it wasn’t allowed to load because it wasn’t signed. I tried to sign it but none of the tools necessary to sign were available on ipfire. I tried manually signing the module on my computer but couldn’t figure out how to load the key I created into IPFire’s key database. Again the tools for signing and key management are not available or install-able with pakfire. That’s when I started this thread to figure out what the proper way install was.

-Greg

I did a bit of digging and it looks like those vid:pid combinations are supported in the 4.16 kernel (and later). IpFire is on 4.14 and likely to be there for a while, AFAICT.

https://cateee.net/lkddb/web-lkddb/NET_VENDOR_AQUANTIA.html

It looks like you’re out of luck, now that the drivers are signed.

There’s the tag “Preformatted text”, which should resemble to this as behavior and than should not change for encoding the char your’re using.
echo "1d6a 87b1" > /sys/module/atlantic/drivers/pci:atlantic/new_id

You’ll see that I’ve used the preformatted text tag on many occasions. I forgot it in this case. I’ve now rectified the omission.

Sorry but the atlantic kernel modul doesn’t support the 10G Version’s of the ACQ1xx cards. The support for this hardware was added with Kernel 4.16 so there is no support for this card in IPFire yet.

Any ETA for supporting more 10G 2.5G and 5G adapters?
Obviously i won’t take any date or period provider as granted…

We currently support plenty of 10G adapters with common chipsets from Intel, Broadcom, etc.

There are some more obscure ones on the market - like this one which I have never heard of - which will be supported eventually when we rebase our kernel on a fresher release of an upstream Linux kernel.

Upgrading the kernel version was being discussed last January.

The development team did not formally discuss this anywhere, but it has come up on here a couple of times.

So far we have no hard reason to do this, because it keeps us busy for months that is simply not possible right now.

Linking to the thread wasn’t meant to imply anything, other than to point out that it was being discussed. I perfectly understand why you prefer to stay on LTS kernels.

Yes, that is absolutely required. 4.19 is already too old, but a new LTS kernel is not in sight, yet. I hope that we will be able to upgrade to that one which will support more hardware of course.

are you serious? My message started off that whole thread… This original message was from
16 Jan… your literally replying to a message from Jan 16. It’s the month of May.

:roll_eyes:

I was linking to the thread. That’s all.

And it’s still relevant to this thread.

I completely understand desiring LTS kernels and I certainly understand that it can be difficult to keep up with kernels so I don’t really consider the solution to be upgrading the kernel unless a feature in a newer kernel is the solution to your problem. I do however think there should be a way to install updated drivers. The AQC-107 may be a more obscure card but it is supported on linux. AQuantia (now owned by Marvell) provides the GPL driver source on their website. The readme inside the source says that kernels 3.10 and above are supported. I just don’t have a readily obvious means of being able to sign (or get signed) the binary that I have produced. I also don’t see a means of turning off module validation (at least for experimental purposes). Unless I’m missing something (and I readily admit that even after years of being a full time linux user and despite being a software developer, I’m not a linux kernel expert at all) I’m stuck here.

All that said, thanks to everyone for all the help. I’ve learned quite a bit.

-Greg

You can open a ticket if you like and link that driver. Potentially that can be added to our kernel, but it would be difficult to compile it manually and load it into the kernel. The IPFire kernel is protected that you cannot do that.

I’ll open a ticket as you suggest.

Thanks,

-Greg

1 Like