Installation assistent errors


I’ve encountered 2 errors while installing ipfire.

First: Definition Network strukcture / assignment network cards

The list of available / not assignet network cards is used to be updated whenever a nic is assigned to a interface. However with having red/green/blue/orange interfaces, after the second assignment, this card is still listed to be available / not assignet. After assigning the third card, the nic (second assignment) also disappears from the list.

Second: There was something missing, when I was asked to restore the backup.

Hi @xperimental

I just tried doing a fresh CU169 install on my virtualbox vm and I could not duplicate your effect. Here are the screenshots of interface mac availability in sequence that I carried out.

Do you only see this effect when you are doing an install from a backup iso that has been created by IPFire or also with an install from the iso downloaded from

The above was with a freshly downloaded CU169 from

I will try a backup created iso with restore later on when I can make some time.


with setting up a backup the assistent won’t go through the network configuration at all. I’ve seen this behaviour many times, I guss every time, in VM and local hosts. I’ve just setup IPFire on vSphere Hypervisor yesterday and selected green, MAC diapperde from the list, selected blue, MAC didn’t disapper from the list so I could select the already for blue selected nic again for orange. First I thought it’s related to the selection of the blue interface, so I tried the other way around and first selected blue and afterwards green. When I come to orange the MAC for green was still at the list. Since I don’t want to play around on productive systems, I will wait until the vLAN problem with the hypewrvisor is solved and create a display video of the szenario.


On productive systems the problem may not appear, because they do/should not run in a VM. :wink:

Mine is going to run as VM. Years ago I said the same and Michael told me the opposite.

See this wiki page about VM’s, written by Michael.


Have searched the history. Must have beeen before 2019. On the other hand you put IPFire on Amazon AWS/EC2 and don’t like to run it as a vServer??? Truly it’s a risk, but every computer center / vServer has that security risk.

The performance is why I dropped a Linux host running VirtualBox and switched to a bare metall Hypervisor.

So I just had the same today again. I added a wifi nic to my mobile rpi4 installation so I exüanded the zones from RED+GREEN to RED+GREEN+BLUE.

I started the setup and removed the onboard wifi from RED. I started to assign the onboard wifi to BLUE. Both “free” wifi nic showed up and I assigned the onboard wifi to BLUE. I wanted to assign the USB wifi to RED and got the error: no unassigned nic left. That’s wrong in the first place.

So I removed the onboard wifi from BLUE again and assigned the USB wifi for RED first (both unassigned wifi nics showed up again).

After that I wanted to assign the onboard wifi to BLUE. However still both wifi nics showed up for selection. That’s wrong in the second place. However of course I assigned the “real” free onboard wifi for BLUE.