I586 Legacy: No admin account created

Just installed I586 on an old Compaq Evo P4, it is working as it should in the sense that I was able to connect to internet from inside the green subnet but:

  1. No admin account was created.
  2. I can’t connect to it with ssh from the green subnet.
  3. I try to get into the web interface but get stuck at the login window.
    Since I have no admin i have tried to log in with root but I suppose that is not permited either. I also created an admin account manually but that didn’t work either. I am rather new to Linux and would appreciate some help in that department too.

Last question, is i586 as secure as the 64-bit version? I realise performance is lower but for my system with very little traffic I am mostly concerned about the security.

Step 4 of install

32 bit is not recommended.
Use 64 bit machine.

GUI/WUI login

Normal it is not possible to complete the setup without setting the password for the admin user. It should always reboot into the setup without finishing the initial config.

This is default. You have to enable ssh in the web interface.
login as root and run “setup” to reset the admin password and go to the

The i586 version is less secure because many hardware features like NX-Bit can only used in x86-64 mode. Memory protections are emulated (much! slower and often easier to hack).
Also the KPTI-patchset for the actual Intel Poblems are not backported to 32bit.

Maybe I am confused then, when I say there is no admin accout created I mean there is no linux account with the name admin created. I do give the admin password where it should go but still, is the admin account just an internal webserver account?

The admin account is stored in /var/ipfire/auth/users.
Have you tried to login to the WUI?

I have tried to login to the WUI. In the users file the only line says: admin:$2y$07…
When I try to change password for admin i get “passwd: user ‘admin’ does not exist”

It is correct that there is no admin user account for linux. It is only for the WUI.
Run “setup” to set the password to a known value and try again loggin to the WUI

1 Like