How to check if a foreign DNS is up and running?

Yesterday I found that some fqdn could not resolved by my PC. I check the IPfire and see that my two DNS shows ‘failed’ when checking. They were from Digitalcourage and I found that they are demissioned. So I choose some other DNS ( and and try again … same error. Ooops?!
I added two more DNS ( (Quad9) and (Digitale Gesellschaft Schweiz)) and try again. Now DNS is working. But if I check the DNS in IPfire I get a ‘failed’ for and For and I get a ‘OK’.

If I use dig at my PC I get the same results. If IPfire shows ‘failed’ a dig in VT shows a ‘timed out’

Today this behavior is the same. I could not believe that these two DNS servers are offline so a long time. Is there way to get more info about the status of this DNS?

Can anyone confirm that these both DNS are unreachable?

I am using some of the ones you have listed and not having any problems. All show OK for the individual servers and Working for the overall system.

Here is my current status

I also checked my logs for any SERVFAIL messages and in the last three weeks there have been zero and before that about 10 in 2 weeks so they have not had any problems that I have experienced.

I am using the TLS protocol for the DNS communications.

1 Like

I just tried all of these out and all gave an OK

If you are still getting an error with some of them then hold the mouse pointer over the error word for a short time and a pop box will show a message for the problem being experienced.

You can also look in the wui logs menu under System Logs. Select “DNS: Unbound” in the drop down box for section and press Update and you will see the logs. This should give additional information on the error message.

This did the trick!
Thank you for the hint!

1 Like