How and where to file a bug report?

Hi,

I’m not new to IPFire, but certainly new to this community. I had to buy new router hardware recently and noticed that the “Beep when IPFire connects or disconnects” does not work. But it did work when I temporarily installed pfsense. How and where do I report the details of this?

1 Like

Hi John,

please head over to https://bugzilla.ipfire.org/. You can log in with the same account you used here.

However, are you sure this is a bug? Do you think that the beeper just doesn’t work with IPFire?

Thanks for the link Michael. If it’s not a bug, what else would it be? The piezoelectric speaker works in pfsense when it connects, but not IPFire.

Can you just run beep on the console and see if you can hear a beep?

Michael, That does surprisingly work and I hear the router beep with that command. Let me know what else you’d like me to try, further details, or whether I should move forward with a bug report.

Which configuration has you red interface?

The beep setting in the gui is only for dialup connections (PPP)

Arne.F, Red is ethernet to cable modem to ISP. Are you sure it is only for dialup connections? The wiki doesn’t reflect that:

https://wiki.ipfire.org/configuration/system/userinterface

And thus I assumed it operated in the same way that IPCop used to with it’s beeps.

1 Like

Hi all

So that the Beeps work on the machine on / off, in SSH I execute this:

ln -sf ../init.d/beep /etc/rc.d/rc0.d/K99beep

ln -sf ../init.d/beep /etc/rc.d/rc3.d/S99beep

ln -sf ../init.d/beep /etc/rc.d/rc6.d/K99beep

I don’t know if it’s correct but it works for me.

You tell us

Regards.

1 Like

This is a different function. It beeps at startup and shutdown.

The other one is a short beep at connect and disconnect, but this works only at dialup. (I plan a change to get this also with dhcp and wlanclient working but this is not implemented yet.)

Arne.F, But this is the function I’m discussing and having an issue with. Not dialup connections.

The checkbox “Beep when IPFire connects or disconnects” is currently only for dialup connections. Dhcp and static will enabled and disabled but has no connect or disconnect function so this switch will do nothing.

Can a checkbox be added when IPfire will ping a defined ip address?
IPFire can ping the host ->beep
IPFire cannot ping the host for 10 times consecutively -> double beep/dual tone beep
IPFire can ping the host again for 5 times consecutively ->beep

Arne.F,

Ok. It seems I was mistaken as to how this feature functions. Which in my case it doesn’t. Thank you everyone for your input and help.

In core139 IPFire now beeps at up and down for every connection type.

@Pike: this need an extra program that do this in a loop. I think we don’t want such programm run everytime…

2 Likes

Arne.F,

I just noticed this with the upgrade to core 139. It is wonderful! Thank you so much! I don’t know if it is the hardware I have or how it’s been implemented in the software, but the beep sequence is short and the volume is just loud enough to be heard without being obnoxiously loud. Well done! :slight_smile:

Hi,

I have 2 identical systems - APU boxes.
One is with PPoE (PPP) and one with static IP.
One has checked " Beep when IPFire connects or disconnects" one does not have it checked.

Both BEEP at start and shutdown.

/etc/rc.d/init.d/networking/red.down/99-beep
/etc/rc.d/init.d/networking/red.up/99-beep

Is there a bug filled for this, or this is by design? To BEEP no matter the setup and check mark for " Beep when IPFire connects or disconnects"

If it is by design to BEEP, please put a check mark to disable it…

I will erase the rc.d files for beep for the moment

Late edit: cgi-bin/gui.cgi seems to have a bug: it does not drop the nobeeps in /var/ipfire/red
I added it manually.
Do I fill a bug?

grep nobeeps -R /srv/web/ipfire/cgi-bin/
/srv/web/ipfire/cgi-bin/gui.cgi: system (’/usr/bin/touch’, “${General::swroot}/red/nobeeps”);
/srv/web/ipfire/cgi-bin/gui.cgi: unlink “${General::swroot}/red/nobeeps”;