Hello why i don't have a pakfire list

Hello why i don’t have a pakfire list

To get this lists IPFire need online access so check that the IPFire is online, the time is correct set and dns is working. After this click on “Refresh list”

1 Like

ipfire works as a router. The internet is available. Here is my dns… What to do with them?

what happens when you click on “Refresh List”?

Nothing has changed. And why is it written broken next to dns status?

There is some problem with your DNS as the overall status is Broken in red.

I note that you have ticked the Use ISP assigned DNS Servers but you don’t have your ISP DNS servers listed so that indicates some issue with your Internet connection not fully working. Also your selected DNS servers are failing to get a Reverse DNS lookup.

Go to the Logs menu and select System Logs then choose DNS: Unbound in the dropdown box and then press the Update button. In the logs theer should be some indication of what is happenning with the DNS server attempts.

You can also choose RED to get the logs for your connection to your ISP to see what messages there are about that.

1 Like

looks like unbound is not running or cannot validate DNSSec.

Go to console and check the system-time with “date”.
dns can only validate with a correct clock settings.
If this still fail try to run “unbound-anchor” to redownload the root-keys and
/etc/init.d/unbound restart

My dns log. There is nothing on red

Ubound -anchor screenshot

Your DNS log messages look like they are having problems with key trust validation.

Your unbound-anchor command is having trouble making a udp connection.

On your main page of IPFire can you confirm that you have an IP address against Internet and also one against the Gateway Line and that the gateway address is what you are expecting from your ISP.

To confirm your RED connection is working, note how many days since you were connected which will be shown in the Status section to the top right. Then go to the Logs/System Logs page, select RED and set the date to the number of days (from your status) before today. As example, my system last booted/connected 30 days ago so as it is 31 today I selected 1 Jan and I got my RED connection log information.


Thanks everyone for the help. I don’t know what happened, but after rebooting the ipfire again, everything worked out. Thank you

1 Like