Firewall network name stuck as "ipfire"

I have just installed IpFire an have it all working except that I cannot see where to change it’s network name on the GREEN network.

In “setup” the name on the RED net is set to FIREWALL and that is being reported OK by the upstream service.

I want to use the same name on the GREEN network but I cannot see where to change it. In “setup” I have tried changing the domain name from “inet” to “FIREWALL” and also “FIREWALL.inet” but it insists on using “ipfire”.

Pinging (the firewall on the green net) works OK
Pinging “ipfire” also works OK.

I suspect its a newbie error :wink: What am I doing wrong ???


Have you rebooted after changing the hostname and domain in the setup?

Yes I did.

The name on the RED network changed and was reported correctly by the upstream system, but the GREEN network only responds to “ipfire”.

BTW I am using " IPFire 2.25 (i586) - Core Update 142"

Thanks for the prompt response.


You have to set the new hostname in setup (Not for red) save and reboot after this change.
Then the system should report the new name on longin prompt and also in the local dns cache.
Keep also in mind that the clients may still cache the old name.

Type in setup on the console window and you will see the menu from the installation.
Change from there.
Hope that helps

The host name is DEFINITLY set to “firewall” under “setup”.

With the firewall powered down and my laptops DNS cache flushed I get NO response to a “ping” of either “firewall” or “ipfire” indicating that its NOT cached anywhere.

If I start the firewall, then on the green network it responds only to “ping ipfire” or its IP address (

The upstream service reports “firewall” as the host name.

Going to the config webpage it shows “firewall.inet” on the home page.

A reboot makes no difference.

What on earth is going on ??


did you by chance define a host with name ipfire and ip in the gui (Network > Edit Hosts)?

No I do not.


The cause was I had setup SAMBA and the NETBIOS name was defaulted to “ipfire” — I changed that and the problem went away :slight_smile:

It’s unfortunate that the SAMBA package doesnt use the configured hostname.

Thanks all

FWIW, when changing hostname via setup,
in /var/ipfire/ethernet/settings remains unchanged.
It still shows the value that was set during initial installation – even after subsequent reboots.

1 Like