Few (potential) bugs after upgrading to 159 from 158

I have a DHCP connection with my ISP and I need to log onto my ISP’s captive portal before “internet” starts working.

Two things happened after I upgraded to 159,

  • Rebooting after upgrade, dhcpd acquired IP from ISP fine. But the actual ISP gateway was not reachable. For some reason the “gateway” IP wasn’t pingable. Trying “reconnect” from connscheduler did not work. I had to physically pull out the RED cable and put it back before everything went back normal. Still no clue what happened.

  • I logged onto the ISP’s Captive Portal through the IP. But websites were still not opening, I could access sites via IP directly but DNS was in “broken” state. I had " Use ISP-assigned DNS servers " option disabled and was using ( one.one.one.one ) and had TLS enabled. I had to disable TLS and re-enable ISP assigned DNS servers and then again disable ISP assigned DNS servers and enable TLS only then the DNS went out of “broken” state and sites began loading fine.


depending on the actual implementation of your ISP’s captive portal, both issues are caused by it, especially the second one.

The correlation with having upgraded your IPFire machine is striking indeed, but might be related to the captive portal only becoming active if the machine has been disconnected or rebooted.

Therefore, I do not believe IPFire in general or Core Update 159 in particular is responsible for this. :slight_smile:

Thanks, and best regards,
Peter Müller