Error messages in boot, IPFire no longer works

My netbook had been broken for a long time. I fixed it and IPFire was already installed in it. It was version 2.17, core 98.

After a couple of days, I decided to let pakfire update it. It was advertising an update to core 100. After the long procedure, it was in fact updated to core 102.

Then it told me there was an update to 120. Hmm. I updated again.

Then I noticed new errors in the boot sequence.

I was going to come ask about them here, but then pakfire was advertising an update to core 131…

That is annoying because I have a monthly data usage quota. Why can’t it update ONCE? Anyway, I chose to update once again, guessing I would end up on core 160 eventually, after God knows how many updates.

But now, after the boot, IPFire isn’t working anymore. It gets stuck at this point:

It remains there for a long time. So long I gave up and tried to hard reset. But instead of hard resetting, it shutdown gracefully. After a new boot, it got stuck again. Then someone wanted to talk to me and had my attention for while, and when I came back IPFire had actually gotten past the stuck point, but with more error messages. And the access point is not working so I can’t connect to it and I can’t SSH either.

Uh, help?

Someone else might have some tips on how to resolve these boot errors.

If I was confronted with the same issues I’d probably be going for a fresh install of IPfire.

Sorry can’t be of any more help.


There are some problems if you try to update such old versions. (IPFire 2.17 is 6 years old)
Too small boot partition, DNSsec rootkey change, switch pakfire from http to https …

Also the updates are much too large. I think you have to download around 10times of a fresh install. And some updates need a reboot to get the next set…

I recommend fresh install and if the hardware is i?86 you should upgrade it to 64bit because we will drop support soon.