Error in Boot 146 core

Hi.

I have seen this error during the IPFire startup in a clean installation:

Creating Squid swap directories...                                     [  OK  ]
Starting Squid Proxy Server...
2020/07/03 09:03:54| WARNING: BCP 177 violation. Detected non-functiona[  OK  ].
RTNETLINK answers: No such file or directory
Adding static routes...                                                [  OK  ]
Adding static routes...                                                [  OK  ]

What could be the problem?.

Regards.

Squid is missing ipv6 localhost which is normal on ipv4 only machines. This message is not new but it was only showed if the proxy is enabled.

3 Likes

Hi,

there is no problem.

‘squid’ is just testing IPv6 availability.

See:
Squid 3.5.7 is available

IPv6: improve BCP 177 compliance

Since early 2012 it has been mandatory for new or upgraded Internet
connected machinery and software to support IPv6 ad use it in preference
over IPv4.

Squid IPv6 behaviour has followed these practices since well before the
guidelines became a BCP. Over the years it has also grown into a
well-tested and widely used feature.

The --disable-ipv6 build option is now deprecated. It is long past time
to fix whatever network brokenness you may have that made it look
attractive in past years.

Squid-3.5.7 and later will perform IPv6 availability tests on startup in
all builds.

  • Where IPv6 is unavailable Squid will continue exactly as it would
    have had the build option not been used.

    These Squid can have the build option removed now.

  • Where IPv6 is detected but --disable-ipv6 prevents use Squid will log
    “WARNING: BCP 177 violation”.

No need to worry. I see this message since 3.5.7 - each time I restart squid from console…

HTH,
Matthias

EDIT: Four minutes late…thanks, Arne… :nerd_face:

3 Likes

Wow, How fast the two !!! Thank you very much. I am more quiet now.

Greetings and thank you very much.