DNS server Status broken

That’s because you are using cable internet, I am using fiber optic. And I tried another router without restarting the modem and it work right away, its an openwrt router. The only reason why I wanted ipfire because it is linux base, and the APU board that I installed ipfire has a realtek nic, linux base routers works better with realtek than freebsd based like pfsense/opnsense.

1 Like

Hi @linuxgeek.

A strange idea.

Haven’t you created a Firewall rule that prevents communication with this?:

I tell you this, since I once created a rule that prevented outgoing communication to certain countries and I marked this and the DNSs did not work.


1 Like

It is a fresh install, so I havent created any rules yet. Whatever the default rules are, is what is in the current settings of the firewall. I did a test again by connecting the ipfire to the lan side of my pfsense, and it work, basically the pfsense is the one resolving any request, it also became a gateway for ipfire. My thought is it is probably a DNS server issue with ipfire, probably the implementation of the DNSSEC.

If your isp hijacks all dns requests from your connection and sends them to their dns server and they do not use dnssec validation then you will end up without any dns resolution capability.

dnssec validation is done by default in IPFire and can not be turned off.

1 Like

I totally understand what you mean. What I am confused is with my instalaltion why it can not ping the gateway provided by ISP. And because of this DNS server will fail also. However if the connection is passed through the pfsense router, ipfire can ping the gateway provided by the pfsense. I think this is really where the problem is?

Yes that is confusing.
I have a fibre connection and I just tried pinging my gateway and it worked fine.

Does your main page show your Gateway IP and your Internet IP correctly.

What message do you get with the ping. Does adding the -v verbose option give any more info?

1 Like

Yes, the main page shows everything correctly. Public ip address, gateway, dns. When I ping wihtout the option verbose, it onlly says host unreachable.

host unreachable suggests a problem with the routing to get to the destination.
dns shouldn’t be a problem here as you are using the gateway ip address for the ping.

What does the routing table look like if you run route -n in the console?

I will check it in the CLI. For reference I have a picture on my previous post of the routing table through the GUI.

Sorry I missed that the routing table was in one of your screenshots but it has raised a question.

In the command line screenshot it shows the gateway as
but in your wui routing table it shows the gateway as

On my system both show the same results, which is what I would expect.

Is the wui still showing or has it changed to

I would not expect the gateway to be changing from one time to another. Mine has been fixed since I started with this isp.

That’s because I already restarted the appliance many times. And the WAN is basically dhcp.

I would expect your ipfire ip to change when you reboot but not the isp’s gateway ip.

The gateway it does change. Depending on the ip address that they assigned.

Yes it changed also to the correct gateway and within the subnet of the ip address.

I am wondering if anyone else here who is in Canada, British columbia using ipfire and have Telus as the isp.