Disable STP on v2

Good Afternoon,

I’m a bit new to ipfire, and the DC that I have my instance running at doesn’t like it when STP is enabled on the public (or RED, as it appears to be with ipfire) uplink, and I’m struggling to find any documentation on how to disable this on v2.25. All I can find is documentation on how to do this on the v3 one, which doesn’t appear relevant here:

I can’t find this option in either the web interface or the setup command utility (which is the only place I’ve been able to find to interact with the network at all). I would appreciate any assistance in guidance on how to disable it! Thanks!

IPFire-2.x not use a ethernet bridge on RED so also no spanning tree.
This wiki page is for IPFire 3.

1 Like

Did you configure your RED interface as a bridge for any reason? That will automatically enable STP.

Nope, I had just followed the default setup, so no bridging that I knew of. I think I have it figured out though - user-error on my end with my virtualization I’m using for ipfire, so probably nothing to do with ipfire itself. Thanks for the responses folks!