DHCP on red interface since core update 159


Since updating to core 159 (I also tried 160), the dhcp on red isn’t working properly.
I do get a dhcp lease, but I can’t ping WAN. This is running on ESXI 6.7
It worked perfectly on core update 158.
Any ideas?

Hello @pyfrancoeur! Welcome to the IPFire Community!

It looks like something is wrong in the RED interface. Did you try a simple reboot?

Access the IPFire box via SSH or via the Serial Console and run setup. Look for:

And make sure things look correct.

1 Like


I did go through basic troubleshooting, (I am a network engineer :stuck_out_tongue: )

It seems that if I “Physically” unplug the card it starts working normally. Physically is in quotes here due to the fact that the cable is still plugged in, but I disconnect it from the virtual interface.

This exact setup worked flawlessly on the older kernel, but since the update it just stopped working.
I can ping the wan IP assigned to me from the console, but not the ISP gateway.
Routes are properly applied on boot, yet they do not work for some reason…

Doing /etc/init.d/networking/red stop / start does not fix it either. I really need to “unplug” the cable for it to go up… Any ideas?

Sound like a driver bug… which virtual nic have you configured?
(Im not sure of ESXi support different types)


I tried with the VMXNET3 and the E1000 nic. Both show the same behavior!
However, I have anothe router running on proxmox, and It is running flawlessly…

A driver bug sounds likely, is Ipfire running custom nic drivers or the built in kernel ones?

IPfire use builtin drivers for all nics except some WLAN chips (realtek and xradio)
also we have only some patches that fix nic issues. (igb, e1000e, mcs7830, ath?k, iwlwifi )


This is so odd…

I guess I’ll migrate my environment to proxmox!
Actually, I’ll try with a SR-IOV nic to see if the issue is present

Well no dice… anyone else running ipfire on ESXI?

I did a fresh install of core update 161 and everything worked perfectly, but I get the same red interface bug after a reboot.

Any clues?