Core 139 won't connect internet

After updating to Core 139, my system unable to connect to the internet. Reboot will not initiate the connection to modem. My work around is to remove red interface and add it back then all the network services restart. The auto network reconnect is not working, I think. Anyone has similar issue with core 139.
System: APU2C4

What kind of internet connection on RED do you use?

I use comcast internet with my own modem + ipfire red connect as dhcp. After the update, my ipfire unable to reconnect to the modem. Reboot did not work. so I remove the red interface and reconnect it back and it is connected. But couples days ago, we have a power outage for a few second so my internet connection drop. Normally it work boot backup and connect automatically but this time it just show connecting. Just want to know anyone having similar issue. I switch to my backup box run clean install with core 139, run system restore and I am back in business but I also found another issue with IPS would not run. I think someone has report that bugs. Thanks

In case of cable modems and power outage, it is best just to wait until the modem has fully connected to the ISP and then to restart IPFire.
It is also possible, that the power outage evokes a disk check and IPFire waits for user reaction on the console during reboot.


this my own expeience:

IPFire is relying on harddisk without errors,
it reacts catastrophic to multiple suddenden power-offs.
Even Backups may contain errors and may give it on to fresh

Best solution: install fresh IPf and configure it new via web-frontend.

Greetings minix

I think that is my best option. I have very simple setup so fresh install is not an issue. My old desktop with serial interface has been decommissioned so I need to order an serial to usb just to configure the setup to assign network interface. Unless someone can show me how to take just the network setup file and add to the image file. Thanks guys!

Uploading config files via ssh and restart also works.

I love IP-Fire.

It is a simple to understand and useful solution to impove
your control and information about your internet and LAN. connections.

Pls. dont use Photo-cards . You better use industry flash memory.

greetings menix

1 Like

Hello ,

my preferred installation is a dual core opteron 1210 (1,3/1,8 GHz).
Its my samba server running under IPF. I use as nas.

Due to electric power amount I run it only on demand and it’s shut down properly by timer (connection scheduler) or manually and it works for some years without flaws.

Multi core systems leave more performance to the web interface so you don’t have to wait so much.



I was able to get my APU2C4 back but still having same issue where the red interface refused to connect to my modem. Note: I am using ssd not SDCard. This is a clean install and configuration. I think there maybe something changed with core 139 cause APU board not to auto connect, I could be wrong here. My backup, minipc with celeron j1900, is runing core 139 without any issue. I am waiting for the next core update to see if it fix the problem with my APU board.

Hallo lowemissions,

did you change ports to exclude single port hardware issues
I.e. use former red as green and vice versa ?

I myself have the same problem. My fw. is connected via fixed IP to by my via ISP provided Hardware and after restart of my ISP Router I have to restart my Firewall to
reactivate name reslolution.



Hello lowemissions,

sorry did’nt read your 1st post correctly.

Seems to you have other issues.

I am using former Wortmann FW with LEX V900D Mainboard ( and
it seems I don’t have any hardware related issues.
Ok, QOS is not displayed, but it dosent bother me.

What if You try an notebook HDD in your APU2C4.



APU2c4 have 3 ports. Yes, I have try to switch to another port but still having the same result. I even try pfsense and it is working fine so I can rule out it is not the port. Maybe I could try clean install on older core 138 to see if it fix the problem. Normally things does not break without any warning.This only occur after I upgrade to core 139 so I think something with core 139 causing the issue. My backup system is actually faster then the APU2 board so the APU2 board will be my experiment board for now. Thanks for the follow up.

Have you installed from the iso or copied the flashimage to your APU?

If you have copied you should enabe the journaling on root.
tune2fs -O has_journal /dev/sd?3

The journal is disabled to use cheap flashcards but on a real ssd you should turn it on because it is more reliable.

I used the flash image to flash to my ssd on my APU. I have done this a dozen of time before so this is not the journaling. When I have sometime, I will try clean install again. Thanks.