Core 139 final version

works well. Thank you.

1 Like

Just updated from core 138 and noticed a possible issue on console while watching the upgrade log file with tail:

tail -f /opt/pakfire/logs/update-core-upgrade-139.log
./ line 53: [: missing `]’
[ FAIL ] SSH Server…
Starting SSH Server…
Unable to continue: /usr/sbin/sshd is running[ WARN ]
Generating grub configuration file …
Found linux image: /boot/vmlinuz-4.14.154-ipfire
Found initrd image: /boot/initramfs-4.14.154-ipfire.img

Is this missing ’ something I should worry about? Did not restart so far.

1 Like

Looks like it wanted to do something with the SSH server but the deamon was still running so it couldn’t access the necessary files?

OK, this would explain the [FAIL] with the SSH server but not the missing ’ in, right?

I’m not sure if I should reboot or if I’ve to fix sthg, that might not have been updated or installed.

What is behind line 53? I don’t know but if I would have written the update script I would expect a return code for everything I’m updating and maybe this is related to the failed update procedure… you never know.

I don’t have that file so I can’t have a look myself. Better you wait with the reboot for a more qualified answer :crazy_face:.

I don’t have or see this file neither. I guess it’s a script that is executed during the update and gets deleted afterwards.

Just tried to reconnect to console, using SSH, and it does not work, connection refused. Still did not restart so far.

I fear, after restarting, that IPFire does not properly boot now and what’s more, I cannot access the console anymore.

So what to do?


Have a Look to the wui under System-Ssh

I have to set the checkbox for password auth.

1 Like

Did not change anthing before and after the update.

During update I was logged into SSH and followed the update process tailing the appropriate log file.

I stayed in console and left home. After my return I was logged off and a retry now fails. Hence, I fear that after a restart this issue persists.

Success! I followed your idea and just pressed the save button in WebIf in menu SSH Access and could re-login, at least using aterminal client on my Android tablet.

This leaves a last question, though: Am I save now with a restart despite the above metioned error with the missing ’

This question i can not answer for sure sorry.

@hellfire it looks like the boot configuration has updated successfully. The machine should reboot - whether to a workable system is uncertain.

At the very least it would pay to download the last two backup files to another PC, before rebooting. It should be technically possible to recover the log files, from the disk of a system that does not work properly, if those are important to you.

I’ve made the core 139 update on my IPFire testing-VM and saw the very same error with a missing '.

Additionally, when shutting down the VM with IPFire, I saw the following error, don’t know if this is specific to the VM or if it is also happening on real hardware. Did not dare to reboot my productive IPFire so far.


Ok, just dared to reboot and after a while the firewall was responsive again.

The virtual one or the other one?

First the virtual one and then the real one. Both reboots went fine.

rpcbind is not touched since September 2018 so i don’t know why the symlinks now fails.

I have messed up the convertion of the nobeeps config file (in line53 i had forgotten to && before the move) and also the new cgi is missing. I will fix this with core140)

If you want to manually disable the beeps run:
touch /var/ipfire/red/nobeeps

Ah, that’s the cause of this issue. Since my APU-Board does not have any speakers, I’m not affected by any beeps either.

The rpcbind error only appeared in the VM, hence, I do not care.