Cannot Fresh install IPfire, "repair filesystem" error on first boot

I am trying to install the latest IPfire version onto an x86 Intel J1900 Nuc

Each time after first reboot I am getting this error

“To get more debug information in the report,
reboot with “rd.debug” added to the kernel command line.
Dropping to debug shell.
(Repair filesystem):/#”

I have tried wiping and reinstalling multiple times but this occurs every single time on the first boot off internal the hard drive and I am stuck for anyway forward.

I have googled this and found it was a known bug reported in April for IPfire. But for the life of me I cannot find a fix for it.

Can you please fix this or offer a simple step by step solution to overcome it.


and which bug was that precisely?

Thanks, and best regards,
Peter Müller


that bug has been fixed in the stable release of Core Update 167, see the Bugzilla entry for details.

From this sentence, I assume you are trying to run Core Update 169.

In this case, you are most probably bumping into another bug. To give us a chance to figure out what is going wrong in your case, please provide the following information:

  • What messages are displayed before the prompt? (Screenshot, if possible.)
  • What hardware are you running, especially what mass storage setup?

Thanks, and best regards,
Peter Müller

Yes I am using 169 downloaded from the IPfire website

It is a Qotom Q190G4
120GB mSATA Kingston hard drive
Samsung (1 x 8GB) 204-pin SODIMM, DDR3 PC3L-12800, 1600MHz 1.35v ram

The hardware is 100% not faulty as I had PFsense on here for four years before wanting to change over to IPfire

A photograph of the error screen I am getting is here


thank you for reporting back.

Since there is not too much information displayed on that screen, may I ask you to provide us with the rdsosreport.txt file dracut has generated? It should contain all the information that have agglomerated during boot, where we hopefully find the root cause for this.

Thanks, and best regards,
Peter Müller


How do I do that?

I have recorded my screen with my mobile phone video camera when all the info was flashing through and took a snapshot of the screens when paused during playback to see if that is any better to discern the issue?

Was that last screenshot any use? If not can someone link me to a guide how to obtain the rdsosreport.txt please.

I think it should be here:

Peter would know better than I do.

It appears in the photo in Post #5

Right, so its located there on my router. How do I get it onto a USB pen drive to move over to my main PC to upload to this topic?

As in treat me as if I know very little about Linux command line.

Are you able to access the IPFire WebGUI ?

If yes, then enable SSH:

Open the desktop/laptop computer console and enter:

ssh -p 222 root@ipfire.localdomain

Are you able to access ?

1 Like

If you have configured SSH access, you can use WinSCP on a Windows system to copy the file easily.

If the system doesn’t boot, as you described, this isn’t a solution. :frowning:
But this link may help.


That is the next step after we make sure the file exists. I am guessing rdsosreport.txt only appears if there is an issue.

Via SSH (check if the file there?):

[root@ipfire ~] # ls -al /run/initramfs/rdsosreport.txt

via your laptop/desktop computer (and not via ssh):

scp -rp -P 222 root@ipfire.localdomain:/run/initramfs/rdsosreport.txt [your desktop folder or downloads folder]
1 Like

I have tried Lan ports 0, 1 and 4 all of them are coming up with a 169 IP address and showing unidentified network.

This is unbelievable the complexity to simply install a router OS onto this system.

I have had PFsense, Opnsense and OpenWRT installed onto this system and none of them brought up any issues but IPfire seems to be a nightmare to get it setup on it.

And for this I am getting "Special device UUID=50CB-4834 does not exist. dmesg(1) may have more information after failed mount system call.

It is definitely the UUID of the USB drive I have checked it 3 times. I then tried reformatting it from FAT32 to just regular FAT and same error.

I think I am going to give up with IPfire. This is just way too complicated to even install.

Anthony - I had the exact same system Qotom Q190G4N-S08 and it ran fine for a few years. It was easy to setup. But the power supply (or something related) went bad and I replaced it last year. (it lasted four years)

Based on your first post I would guess that something needs repair on the Qotom internal Kingston hard drive. Along those lines you may need to boot from a separate USB device (like an external drive) and then run an fsck type command to repair.

This is above my level and I need to defer to someone else for help.


I think that in this situation there is no way to connect through the network, because the system did not start completely.
Take a look at this topic:

Have you tried to enter “exit” here?


looks like the filesystem on /dev/sda4 is corrupted. Mount reports that it detect more than one filesystem on this disc. Are you really sure that this disk is OK?

1 Like

“looks like the filesystem on /dev/sda4 is corrupted. Mount reports that it detect more than one filesystem on this disc. Are you really sure that this disk is OK?”

Then for some reason, IPfire is not fully wiping the hard drive before installing the OS to it. When I have time I will try running a linux live CD and wiping the drive and then installing IPfire again to see if this fixes it.

1 Like

Looks like the SSD is buggy and ignore the discard function which linux mkfs use to erase an SSD. (this is the recommended way to clean an ssd because every write of the flashcells reduce the lifetime)