Cache not "caching"

I hold a LAN at my place every 2 months, and as usual the turkeys never update their games, so i’ve been referred to IPfire.

this is my first time using ipfire, im trying to get it setup to make a caching server for steam / origin / windows etc. this is a fresh install, so nothing has been tampered with tick box wise. 2% of the drive is used for installation

i have bugger all knowledge with networking so please be kind.

Cache management has been ticked,

  • All variables have been left at default settings. (apart from the Hard disk cache size, which i set to 50gb"
  • When i Click on “Cache management” it takes me to a user and password. now i left the passwords basic when setting up, Root is root and admin is admin ( this will only be used for updating games, so it’ll be turned on a few days before hand to grab all the updates)
    however, i’ve tried both user root and admin logins and always comes up with incorrect login details ?

update accelerator has been ticked
allocated 75% usage ( it’s a total of 80gb drive for trial purposes) and that’s the only thing ticked in that area

i’ve tried downloading a small game through steam several times, but it just doesnt seem to cache, i click on the statistics & maintainance buttons and keeps saying “Local Cache is empty”
In addition, the kids have been watching youtube and easily watched 30 vids, which once again, still 2% of hdd used


  1. Do i need to tick / untick / adjust anything that enables the cache ?

  2. with the “cache management” does it cache “EVERYTHING” eg, facebook / reddit / youtube /googling / windows updates ?

  3. do i need to add any addons to get stuff like Steam / origin / uplay / blizzard / epic. to get this working ?

let me know if you need any screenshots etc
thanks for your input.