BLUE interface with regular NIC


Hi there guys! First post here(be gentle… :)) ).
I setup my ipfire machine with 3 separate NICs.
Red- internet, Green- LAN 1 and Blue-LAN 2(for a weird monitoring network device…). The Blue must be isolated from the anything else, and access internet only.
The problem is I cannot manage to give internet on Blue. I setup dhcp server, I installed hostapd.
But from obvious reason, the regular NIC is not Wireless card, and I cannot choose the interface. Can you help me please? Thank you!!

Hi,

welcome to the IPFire community. :slight_smile:

I assume you have configured the appropriate NIC for the BLUE interface either during the installation procedure, or later by running setup on your IPFire machine. If so, you are almost there - the MAC filter on BLUE is probably preventing that device from getting connectivity. You need to either whitelist the devices’ MAC address or disable the MAC address filter completely.

Thanks, and best regards,
Peter Müller

4 Likes

Additionally to what @pmueller mentioned:-

In your zone configuration screenshot you have the Blue Interface assigned to its own NIC with the Native connection but then you also have it Bridged with the Green Interface. This means that the Green and Blue interfaces act as though they are one network. You should change the top line for Blue from VLAN to None so that the Blue interface is a separate network.

As you don’t have any wireless card installed you also don’t need to install hostapd. Having it won’t hurt but it is not needed for a wired Blue connection.

5 Likes

Yeap, MAC filter rule did the trick. Works like a charm!
Also I revert the setting from Zone to default, like @bonnietwin said.
Thank you for help! :+1: :+1: :clap:

4 Likes