ASN script stopped working

I wonder if somebody uses maloe’s ASN script for IPFire. I’d like to exchange some experiences concerning configuration. Including Core update 163 the script worked fine in my environment. After updating to version 164 there were no ASN network groups created anymore. I’d be happy to know the reason for this.
Could anybody give me a hint?

Thanks in advance, Pierre

The script (v0.7.12) is still working here on Core165.

Something wrong with your fcrontab entry…?

Hi Hico,
thx for answering my query. My fcrontab entries were fine. The problem is as described under While updating: couldn’t reach (wget) selected source ASN_bgplookingglass. There are in maloe’s script more sources defined for detecting ASN. Well, I had to edit the source code a little bit. I commented out http://www.bgplookingglass.com and I selected https://www.cidr-report.org as default source for ASN instead. Now the script is working again :smiley:

Cheers, Pierre

Hi,

actually, it would be great if this script would be modified by its maintainer to make use of libloc. That way, it would not require to depend on a 3rd party source, and IPFire installations already come with AS information, which can be retrieved via:

location list-networks-by-as [AS number]

(For the medium term, AS-based firewalling is planned, since that is way more useful than location-based rules. No big deal under the hood, but the GUI is giving us some headaches on that front…)

Thanks, and best regards,
Peter Müller

Ask Mike @ www.kuketz-blog.de
The Author: Mike Kuketz, maloe

greetz Hico

Hi Peter,
found the libloc functionality pretty neat and used it in my own scripts but only for catching the ASN for company names with a
location search-as [company-name]
to convert the ASN to CIDRs i used before whois/whoisrequest since
location list-networks-by-as [AS number]
delivered an
usage: location list-networks-by-as --> etc.
longer time ago. Tried it now again with a
location list-networks-by-as [ASN Number only without 'AS' in the beginning]
and it worked great :slight_smile: .

Nice one :sunflower:

Best,

Erik