After update to core 141 no more pakfire list availble

Hi

after the upgrade to 141, if I refresh the pakfire, i get a completely empty list.
What can I do?

thanks
vincenzo

Check that you are online, dns is working and retry and then check the pakfire log section.

Hi

I m quite new in ipfire please guide me…

How can I check if dns is working, I am on line…

Thx

Vincenzo

if you can ping google.com from a client on your green network, dns is working.

PING google.com (172.217.14.110) 56(84) bytes of data.
64 bytes from lax31s01-in-f14.1e100.net (172.217.14.110): icmp_seq=1 ttl=56 time=19.7 ms
64 bytes from lax31s01-in-f14.1e100.net (172.217.14.110): icmp_seq=2 ttl=56 time=18.6 ms

(it resolves google.com to 172.217.14.110 and pings successfully).

I have the same issue and have done alot of troubleshooting. Here’s some things I can tell you:
Computers on the lan can navigate the internet, but the ipfire router cannot. In other words, although a Linux computer attached to the lan can browse and ping servers on the internet via domain name, ie www.cnn.com, the same cannot be done from the ipfire console.

Also, trying to use unbound-control gives a series of error messagess that say it has tried many times to connect and it gave up with the following error message: unbound-control[437:0] error: connect: Connection refused for 127.0.0.1 port 8953

If I go to /etc/rc.d/init.d/ and do ./unbound status, it tells me: /usr/sbin/unbound is not running but /var/run/unbound.pid exists.

And when I check the DNS service in the WebUI, it says Status: broken

Same issue here:



IPFire is online

/etc/init.d/unbound restart and pakfire update(twice) solved my problem

hi guys

no way…
i did everything in this and other posts… but i get the same result:

unbound-control[17687:0] error: connect: Connection refused for 127.0.0.1 port 8953

and on “pakfire update”
Giving up: There was no chance to get the file “2.25-armv5tel/lists/server-list.db” from any available server.
There was an error on the way. Please fix it.
MIRROR ERROR: Could not find or download a server list

ipfire is running but if i ping www.google.it it does not resolve anything…
suggestions?

thx
vincenzo

and…

09:06:50 unbound: [1902:0] fatal error: Could not set up local zones
09:06:50 unbound: [1902:0] error: Bad local-data RR RPI2 - vbtest.localdomain 60 IN A 192.168.2.110
09:06:50 unbound: [1902:0] error: error parsing local-data at 7 ‘RPI2 - vbtest.localdomain 60 IN A 192.168 .2.110’: Syntax error, could not parse the RR’s type
08:59:00 unbound: [17485:0] fatal error: Could not set up local zones
08:59:00 unbound: [17485:0] error: Bad local-data RR RPI2 - vbtest.localdomain 60 IN A 192.168.2.110
08:59:00 unbound: [17485:0] error: error parsing local-data at 7 ‘RPI2 - vbtest.localdomain 60 IN A 192.168 .2.110’: Syntax error, could not parse the RR’s type
08:59:00 unbound: [17483:0] warning: did not exit gracefully last time (15789)

This is a bug that should have been fixed some time ago… it happens when unbound is restarted while the leases file is being updated…

HI

ok… thankls for the info… but in the end… what have I to do to fix this?
vincenzo

Local DNS seems to be pretty borked in 141.

I got local DNS working again (I could do DNS from the host but not from the IPFire command line) by setting (under Network/Domain name system) Protocol to TLS, which doesn’t make sense as I had no TLS name defined and my then-used DNS servers aren’t DNSSEC capable anyway. Now I have added a bunch of different DNS servers, some of them DNSSEC, check the list at https://wiki.ipfire.org/dns/public-servers , and it’s still working, I have no idea why.

HI

I had to reinstall IPFIRE completely from scratch… and now it seems working fine.DNS is not in “broken” status

vincenzo

This is what worked for me. I logged into the console, and typed “sudo pakfire update”, and it updated.

Had the same issue the url from the errors gave me a list of mirrors
Visited this in a Web browser.
pakfire . ipfire . org/2.25-x86_64/lists/server-list.db

I had to ping to get the ip address and added it to the host file.
Also had to add the mirror that i wanted to use.

I accessed the firewall using SSH and used vim /etc/hosts to edit the hosts file.
These are the two lines i added to get the pakfire update to work.
81.3.27.38 pakfire.ipfire.org
130.225.254.116 mirrors.dotsrc.org

Please do not hard-code our IP addresses because they might change.

only did to fix the issue

same error here, what ist broken in 141 ?

after update with setting hosts manuel in /etc/hosts, it is possible to remove the entrys

Thanks @ [Shawn Hilton]

an other Problem after the Update is, that forum.ipfire.org und people.ipfire.org can not be resolved, Internet and DNS in Front of Ipfire is ok, it is a dns-problem of the ipfire

Same issue here with same screens like @xeonium but

/etc/init.d/unbound restart and pakfire update(twice) solved my problem

didn’t helped me!

If nothing other help to get further updates add
nameserver IP
to /etc/resolv.conf

and run
pakfire update --force
pakfire upgrade

to go to core142. Don’t mess with /etc/hosts or other configfiles. (/etc/resolv.conf will regenerated at reboot)